Problema - Instalação i-Educar Relatórios

Olá pessoal, bom dia!!! antes de abrir este tópico pesquisei aqui no forum e não achei nada que pudesse me ajudar, após configurar o ieducar 2.8, tudo blz rodando blz, agora fui fazer a instalação do i-Educar Relatórios seguindo o passo a passo disponivel aqui GitHub - portabilis/i-educar-reports-package: Pacote com as funcionalidades do módulo de relatórios para o i-Educar. após seguir os comandos uma mensagem é apresentada
Please make sure you have the correct access rights
and the repository exists. (Verifique se você tem os direitos de acesso corretos
e o repositório existe)

image

alguém me ajuda, desde já obrigado

cd /var/www/ieducar

sudo git clone https://github.com/portabilis/i-educar-reports-package.git packages/portabilis/i-educar-reports-package
sudo composer plug-and-play:update
sudo php artisan community:reports:link
sudo php artisan reports:install

Isso para a versão 2.7.5

Bom dia!!! agradeço sua ajuda, após rodar os comandos mencionados acho que tem algo errado, já pesquisei mas não obtive um entendimento assertivo

Já aconteceu antes, esta biblioteca cossou/jasperphp as vezes não está disponível no Packgist e é preciso esperar ela voltar a responder.

Boa tarde!!! apliquei os comandos novamente, flui, só que no ultimo comando deu a mensagem " ERROR There are no commands defined in the “reports” namespace. Did you mean one of these?" olhei passo a passo novamente esbarro neste erro :thinking:

Qual a versão do Composer?
Tente:

sudo composer plug-and-play
sudo php artisan community:reports:install

:grimacing: Nossa!!! já estou com muita vergonha, agora rodei todos os comandos blz, sem nenhum problema. só que na aba não aparece os relatórios ?? :face_with_peeking_eye: o que fiz de errado sera, esse foi o ultimo comando que apliquei


ai reiniciei o pc servidor só que não aparece na ABA opção de relatório

Olá, boa tarde!!! alguém ai para me ajudar com essa situação ai

Desculpas, refiz a instalação passo a passo, deu certo agora, agradeço ao pessoal que havia ajudado antes. Valeu.

Estou recebendo o seguinte erro e não sei como contornar:

image

A versão do composer é 2.6.5 e a versão do Laravel é 8.83.27

Em um outro computador, este comando está disponível

image

Caros

Com a ajuda do @moliveirasoares resolvi esse problema executando o comando: sudo ln -s /var/www/ieducar-2.6.9/packages/portabilis/i-educar-reports-package/ieducar /var/www/ieducar-2.6.9/ieducar/modules/Reports .

Porém agora estou tomando esse erro:


a

2 curtidas