Dúvidas sobre o i-educar

Boa tarde, galera! Tudo bem com vocês? Tenho algumas dúvidas a respeito da utilização do i-Educar:

  1. Para utilizar o sistema em produção, o mesmo deve ser instalado somente em máquinas Linux? Além do Ubuntu, existem outros SOs em que também podem ser instalados? Roda suave no Ubuntu 20.04?

  2. Qual a melhor opção para deixar o sistema: em um servidor local ou contratar um serviço de hospedagem na nuvem?

  3. Sei que o sistema i-Educar é um projeto open source. Mas existe algum custo entre a empresa Portabilis e as prefeituras que utilizam o sistema?

Queria a opinião da maior quantidade de pessoas possíveis, assim teria uma ideia melhor de como usam esse sistema na administração pública!

@Almeida20, o i-Educar é open source e não há custo para sua utilização.

Você poderá instalar em qualquer sistema operacional desde que tenha conhecimento para isso, a Portabilis, mantenedora do projeto, fornece suporte em produção apenas para Ubuntu, então em caso de problemas, é mais fácil você obter uma resposta se estiver utilizando tal sistema.

Para utilizar o sistema em produção, o mesmo deve ser instalado somente em máquinas Linux? Além do Ubuntu, existem outros SOs em que também podem ser instalados? Roda suave no Ubuntu 20.04?

Hoje o i-Educar roda utilizando as tecnologias mais atualizadas, então roda suave sim. Detalhe, apenas o banco de dados que está desatualizado, a versão do Postgres é a 9.5 e em breve será atualizada.

Qual a melhor opção para deixar o sistema: em um servidor local ou contratar um serviço de hospedagem na nuvem?

Indiferente, tudo vai depender dos custos que você pode arcar e o tempo para dar manutenção nos servidores.

Sei que o sistema i-Educar é um projeto open source. Mas existe algum custo entre a empresa Portabilis e as prefeituras que utilizam o sistema?

O sistema é open source sem limites de uso, a Portabilis é uma das empresas que presta o serviço de hospedagem, manutenção, consultoria e treinamento em geral para as prefeituras de municípios que são nossos clientes.

Entendi, obrigado pela resposta! Vi que acabaram de lançar a versão 2.5, lá diz que “remove suporte ao PHP 7.3” então só funcionará do 7.4 acima?

Exato @Almeida20, o PHP 7.3 já não tem mais suporte ativo conforme calendário da equipe de desenvolvimento da linguagem https://www.php.net/supported-versions.php.

Em breve queremos liberar o suporte para PHP 8.

1 Curtida