Implantação Inicial


#1

Boa tarde, sou novo aqui e fui convidado por um municipio para coordenar a implantação do i-Educar pois vão adotar software livre la, mais antes de td vou tentar facilitar meu trabalho atraves da Ajuda de vcs que ja são mestres, pedindo sua ajuda com algumas duvidas

1- Como Servidor oq devo usar, Cloud ou VPS ou outro tipo de hospedagem
2- Preciso registrar um dominio?
3- No servidor qual a versão do ubuntu mais estavel?
4- Qual e versão do Postegres?
5- Qual e versão do PHP?

Como disse antes sou novato no i-educar pois trabalhava com sistema de educação off line mais aceitei o desafio e agora tem que rolar kkkkk, aguardo retorno!


#2

Boa tarde @Moises. Naturalmente não sou nenhum expert, mas vou tentar aqui dividir minha experiência pessoal com você, pra já tentar evitar que você incorra nos mesmos erros que eu:
1 - Tentei algumas hospedagens antes, e bati bastante cabeça, até chegar à seguinte conclusão: O sistema funciona muito bem numa vps com sistemas linux (de preferência debian) com kernel 3.80 em diante. Uso com sucesso uma distro linux 16.04 com kernel 4.4.0 numa vps.
2 - Você pode registrar um domínio, ou também pode linkar para o ip da vps de dentro de algum site já existente. Uso isso com sucesso, num site oficial:

3 - Uso a ubuntu 16.04 e ainda não tenho o que reclamar, mas é bom que veja com os mais experientes.
4 e 5 - Acho que é php 7 e postgres 9.5 e a instalação docker já trás tudo isso junto.
Espero que tenha te ajudado e lembre-se que também sou iniciante.


#3

Que bom que divide experiência conosco, vou tentar te responder ponto a ponto como colocou aqui, basicamente o aplicativo é agnóstico a sistema operacional, bastando que respeite o pré-requisitos de desenvolvimento.

Neste aspecto pode se ter a instancia em qualquer ambiente, seja num container em seu desktop, virtualizado ou mesmo em uma VPS pública. Como avisei anteriormente é agnóstica a sistema operacional, por que da escolha? Facilidade na época por conter exatamente o PHP na sua versão v7.0.x e atualmente a equipe portabilis está esforçando para atualizar este requisito, não me recordo que @munizeverton ou @edersoares comentou que a v7.2.x tem EoL no fim do ano.

Nada a comentar. Somente relativo a segurança de toda e qualquer aplicação exposta a publico. Recomenda-se utilizar a porta padrão que é a 80 ou utilizar HTTPS

Está correto os requisito!

Uma correção, o docker não trás tudo isso junto, ele te monta de forma automática o que é considerado **homologado** pelo time da portabilis no ambiente de desenvolvimento. Ou seja, pode se fazer no OpenSuse, Fedora, CentOS e até mesmo FreeBSD. Desde que respeite a versões do PHP, seus módulos e PostgreSQL

Abraços!


#4
  1. Como Servidor oq devo usar, Cloud ou VPS ou outro tipo de hospedagem A sua escolha
  2. Preciso registrar um dominio? Não, mas fica mais interessante chamar pelo nome
  3. No servidor qual a versão do ubuntu mais estavel? O Ubuntu mais atual é o 18.04
  4. Qual e versão do Postegres? Tem que usar a v9.5
  5. Qual e versão do PHP? Tem que usar a v7.0.x

#5

Valeu galera, muito bom poder contar com a ajuda de vcs e aprender mais sobre uma ferramenta tão importante dentro da sociedade, e assim também no futuro poder compartilhar conhecimentos com outros que estiverem em fase inicial como eu. Grande abraço!


#6

Alguem aqui pode fazer a instalação em uma VPS Ubuntu Server 16.04? se sim pode me passar contato para conversarmos!


#7

Está precisando de um freela?


#8

Bom dia, essa semana tentei instalar o ieducar 2.0, seguindo o tutorial da portabilis https://github.com/portabilis/i-educar porem nao conseguir. Ja o tutorial da versao antiga e muito bom, conseguir instalar de primeira. Alguem pode me ajudar??? por favor.


#9

Estou tentando instalar no ubuntu 16.04. Na verdade acho q to tendo dificuldade e na instalacao desses docker.


#10

Essa é a versão de desenvolvimento (mamão com açúcar) mas precisa conhecer de forma razoável a ferramenta docker para ter exito. Se quiser tentar instalar no metal e na unha olhe o Dockerfile que se encontra no docker/ieducar_1604

Se estiver usando o docker, não precisa ser executado no Ubuntu 16.04 rigorosamente.


#11

Obrigado. Vou dar uma olhada aqui.


#12

https://github.com/portabilis/i-educar/blob/master/docker/ieducar_1604/Dockerfile quer dizer q com esses passos vou conseguir instalar o ieducar 2.0 ??? [farribeiro]


#13

Galera eu quero apenas instalar o ieducar 2.0, pra rodar na escola, no momento nao quero desenvolver nada. Alguem tem esse tutorial dessa versao por favor. Porque o q tem aqui seguir e nao conseguir instalar e funcionar. https://github.com/portabilis/i-educar


#14

Afirmativo!

Não existe, ou seja, inexistente tal procedimento no momento.


#15

A Portbilis na verdade era que deveria facilitar as coisas quanto a instalação, para que cada dia mais escolas utilizem o sistema.


#16

Até o fim de novembro iremos liberar um instalador que facilita isso tudo.
Mas é bom lembrar que conhecimento técnico é essencial para tornar o sistema seguro, com backups, etc., e a comunidade não pode se responsabilizar por isso.

Iremos ajudar nas dúvidas técnicas e liberando o instalador.

@cda.marcio precisamos de detalhes do problema que você está enfrentando. O nosso tutorial é para uso local e não para colocar em produção efetivamente. Há outras pessoas colocando em produção, se alguém puder compartilhar como está fazendo.

@Moises Essa facilitação ocorrerá até o fim de novembro. Por hora, estamos focando em melhorias do sistema para entregar a melhor versão possível.

@farribeiro obrigado pela ajuda nas respostas.


#17

Pelo menos um passo a passo bem elaborado que tenha sido testado ante ja ajudaria bastante, pois vemos
é muito desgastante vc ficar fazendo experimentos ate dar certo!


#18

Recomendo que leia, com certa atenção, e tente extrair uma conclusão de todas as dúvidas sobre a instalação. Inclusive o antigo tutorial que se encontra no SPB.


#19

Instalei o Sistema e fiz o primeiro acesso com a senha padrão e funcionou, visitei os módulos e quando alterei a senha o sistema não permitiu mais acesso, ele retorna com este erro, alguém poderia me ajudar por favor!


#20

Bom dia. Obrigado a todos pela atencao.