Instalação do i-educar numa vps


#85

Deu certo meu amigo ROBSON… vc e meu anjo da guarda aqui no grupo… kkkkkkkkkkkkk… valeu… Vamos ter q tomar umas pra comemorar… kkkkkkkkk


#86

Vamos sim, bom proveito.


#87

DEU CERTO NE…


#88

Não, ainda faltam os relatórios creio eu. Verifica se eles aparecem, senão aparecerem coloco aqui os comandos.


#89

olhai como ficou a 1 tela quando logei…


#90

DEU ESSE ERRO QUANDO EXECUTEI ESSE COMANDO NA INSTALACAO DE RELATORIOS.

docker-compose exec php artisan reports:install


#91

Achei nesse topico: Erro instalação banco
Fala em falta de memoria. Sera que e o mesmo caso comigo?
Olhai a configuração da minha VPS.


#92

você tentou atualizar para a versão 2.1.4?


#93

Fiz toda a reinstalação e agora apareceu a tela inicial normal. Ainda não fiz a instalação dos relatórios. Vou tentar agora


#94

Os comandos são outros, os que tem nas instruções é para as versões de desenvolvimento e testes.

Os comandos são:

php artisan key:generate
php artisan honeybadger:install project-api-key

para os dois comandos acima, o ideal é que sejam executados antes da instalação, após a instalação, executar os dois comandos abaixo:

sudo composer new-install
php artisan reports:install

se o usuário for ‘root’, remove o ‘sudo’


#95

PORQUE NAO CONSIGO ACESSAR MEU BANCO COM PGADMIN3


#96

acho que tem que configurar o arquivo /etc/postgresql/9.5/main/pg_hba.conf para conexões remotas, mas eu nunca fiz não


#97

Uai mais seu ieducar nao esta numa VPS tambem? como a minha numa empresa de hospedagem???


#98

não, aqui é um computador do patrimônio.


#99

tentei executar os 2 comandos e deu esses erros. seguindo a orientacao que ja tinha instatado.


#100

executa na pasta do i-educar


#101

Seguir as instrucoes, mais continua dando erro. Instalei o ieducar, depois fiz o clone git clone https://github.com/portabilis/i-educar-reports-package.git ieducar/modules/Reports.
depois tentei executar os 2 comandos na pasta ieducar /var/www/html/ieducar
Sera porque contina dando erros? So falta isso agora pra resolver e dar andamento no sistema pra testes nas escolas. Alguem pode me ajudar por favor???


#102

fez esses passos após baixar do git?


#103

Sim… GIT ta instalado. Fiz os passos depois…


#104

Seguindo todos os passos, ainda continua dando o erros nesses 2 comandos. Nao consigo instalar os pacotes de relatorios.