Instalação do i-educar numa vps


#64

fiz uma reinstalaçãoe agora passou do erro mais para no erro

sera que podem me ajudar ?


#65

conseguir passar da symlinks dando permissão para arquivo install.php , mais surgiu outro erro
sera que podem me ajudar ?
o começo do erro do log
[2019-02-16 08:55:41] local.ERROR: SQLSTATE[HY000]: General error: 7 SSL SYSCALL error: EOF detected (SQL: –
– PostgreSQL database dump

– Dumped from database version 9.5.14
– Dumped by pg_dump version 9.5.14


#66

Eu não passei por esse erro. Eu procuraria no google pelo erro e conferiria pelo pgadmin3 se a conexão com o banco está ok e sem tabelas criadas nele


#67

o problema que não conseguir acessar via pgadmin3 de maneira nehuma o banco dados


#68

Sempre que eu reinstalava o ieducar eu apagava o banco e criava novamente. Se o banco não estiver vazio na instalação, dá erro de escrita porque já está escrito.


#69

muito obrigado eu conseguir intalar esse erro ai deu por causa da memoria aumentei pra 2 giga de memoria e fucionou


#71

Nem eu conseguir acessar meu banco via o pgadmin3…


#72

Aumento a memoria onde? através de configuração no postgresql??? Mande o print por favor com a resolução do problema.


#73

Boa noite pessoal. Fui fazer uma nova instalação ontem usando o docker, e após o comando docker-compose up -d --build
Está apresentando a seguinte saída:

Could not open input file: composer-setup.php
ERROR: Service 'php' failed to build: The command '/bin/sh -c php composer-setup.php --install-dir=/usr/local/bin --filename=composer' returned a non-zero code: 1

Alguém já passou por isso? É uma vps com linux ubuntu 18.04, mas primeiro tentei fazer com o 16, e imaginei que esse erro era por incompatibilidade do php com essa versão do linux. Alguém já passou por isso e pode me ajudar?


#74

Solução já estava aqui no fórum. Basta ir lá em i-educar/docker/php e editar o arquivo Dockerfile. Substitui a linha do post abaixo e seja feliz. Só não tava localizando o arquivo, por isso deixei o caminho aqui.


#75

Pode me ajudar, ainda nao conseguir sair do problema do banco de dados. Ja q vc conseguiu com ajudar do ROBSON… tem como vc colocar pronts de como vc fez pra resolver o problema. Por favor… olhai como ta http://ieducar.conceicaodoaraguaia.pa.gov.br/install.php


#76

Boa tarde Marcio. Essa instalação que tava com problema foi feita usando o docker, e me parece que você optou por fazer em produção, mas isso não vem ao caso. Me parece que você já tá quase lá, faltando apenas alguns detalhes, que devem ser checados:
1 - Já verificou os dados de conexão ao banco no seu arquivo .env?
2 - Você fez alguma mudança de senha ou nome do banco?
Caso tenha feito, é só adequar os dados dentro do seu arquivo .env.


#77

Boa tarde. @marcioro eu estava com problemas na Internet e só vi a mensagem agora. Segue alguns passo que podem ajudar:

  • Criar usuário
    Para criar o usuário do banco ‘ieducar’, executar o comando abaixo:
    sudo -u postgres createuser ieducar

  • Mudar a senha do usuário
    Para mudar a senha do usuário, executar os comandos abaixo:
    sudo -u postgres psql
    psql=# alter user ieducar with encrypted password 'ieducar';
    psql=# \q

  • Concede permissões ao usuário de criar banco de dados e regras
    Para mudar as permissões do usuário, executar os comandos abaixo:
    sudo -u postgres psql
    psql=# alter user ieducar with SUPERUSER;
    psql=# \q

  • Criação do banco de dados
    sudo -u postgres createdb ieducar
    sudo -u postgres psql
    psql=# grant all privileges on database ieducar to ieducar;
    psql=# \q

  • Alterando a forma de envio da senha
    Para que a aplicação i-Educar se conecte ao banco de dados, é necessário alterar a forma de envio da senha. Para alterar, abre o arquivo /etc/postgresql/9.5/main/pg_hba.conf com um editor de texto e permissão de escrita, e altera a seguinte linha:
    # "local" is for Unix domain socket connections only
    local all all peer
    por:
    # "local" is for Unix domain socket connections only
    local all all md5
    Para reiniciar o serviço do banco de dados, executar o comando abaixo:
    sudo service postgresql restart


#78

verifiquei os dados do banco sim, estao iguais ao do instalador.
Nao fiz mudancas na senhas.


#79

Blz meu amigo… vou tentar fazer essas passos agora. Ok. aviso no grupo o resultado. Valeu a todos.


#80

Seguir todas essas configurações, e continua com erro. Quando executei os scripts, deu apenas 1 erro de acesso negado. Sera por isso que não funciona, mais na VPS tem apenas meu usuário ROOT…

“/root”: Permission denied


#81

deu erro aqui porque o usuário é root, no comando que eu passei é para outros usuários, neste caso remove o ‘sudo -u’ dos comandos


#82

Cola aqui o trecho do arquivo .env com as informações do banco de dados. Aqui está assim:

DB_CONNECTION=pgsql
DB_HOST=localhost
DB_PORT=5432
DB_DATABASE=ieducar
DB_USERNAME=ieducar
DB_PASSWORD=ieducar


#83

Tai meu amigo…

DB_CONNECTION=pgsql
DB_HOST=postgres
DB_PORT=5432
DB_DATABASE=ieducar
DB_USERNAME=ieducar
DB_PASSWORD=ieducar


#84

tenta mudando a linha:

DB_HOST=postgres

para

DB_HOST=localhost