Erro na instalação do I-Diário [RESOLVIDO]


#1

Estou fazendo alguns testes com o i-educar (que por sinal, todos foram realizados com sucesso) e gostaria de fazer alguns com o i-diário, mas estou esbarrando nesse obstáculo na instalação e desde então, não consigo soluciona-lo. Alguém poderia me auxiliar?
Já tentei instalar uma versão mais recente do ruby, porém a instalação do i-diário pede que seja a versão 2.2.6, então se for uma versão diferente, da erro posteriormente.


#2

basta alterar a versão do arquivo Gemfile e instalar o ruby padrão.


#3

Fiz isso e uma série de erros posteriores acabaram aparecendo, como segue na tela abaixo:

O que devo fazer?


#4

Qual a versão do Ruby instalado? Aqui funcionou com a 2.3.1


#5

2.5.3, mas vou tentar com a 2.3.1 pra ver se agora funciona.


#6

No ubuntu 16.04 executei o comando: ‘sudo apt install ruby-bundler ruby-dev’ e foi instalado a versão 2.3.1


#7

Segui esse comando agora, foi instalada a versão 2.3.1, mas o mesmo erro persiste


#8

Eu tenho um comando que instala umas dependências, no computador do trabalho


#9

Hum, interessante, você poderia me passar?


#10

Segue:

sudo apt-get install build-essential openssl libreadline6 libreadline6-dev curl git-core zlib1g zlib1g-dev libssl-dev libyaml-dev libsqlite3-0 libsqlite3-dev sqlite3 libxml2-dev libxslt-dev autoconf libc6-dev ncurses-dev automake libtool bison subversion libxslt-dev libxml2-dev zlib1g-dev

#11

Funcionou @robson, muito obrigado pela assistência.


#12

Por nada @henrycastelar