Erro ao importar educacenso 2018

Bom dia pessoal, quando tento importar o educacenso esta dando erro. Configurei o client_max_body_size 50M; e fastcgi_read_timeout 7200s; no arquivo default.conf.

server {

    listen 80;

    server_name default_server;

    root /var/www/ieducar/public;
    index index.php index.html;

    error_log  /var/log/nginx/error.log;
    access_log /var/log/nginx/access.log;
    client_max_body_size 50M;

    location ~ ^/intranet/?$ {
        rewrite ^.*$ /intranet/index.php redirect;
    }

    location ~ /module/(.*)/(styles|scripts|imagens)/(.*) {
        rewrite ^/module/(.*)/(imagens|scripts|styles)/(.*)$ /intranet/$2/$3 break;
    }

    location ~ /module/(.*)/(.*) {
        rewrite ^/module/(.*/)(.*intranet/.*)$ /$2 redirect;
        rewrite ^/module/(.*/)(.*index\.php)$ /$2 redirect;
        rewrite ^/module/(.*/)(.*logof\.php)$ /intranet/logof.php redirect;
        rewrite ^/module/(.*/)(.*meusdados\.php)$ /intranet/meusdados.php redirect;
        rewrite ^/module/(.*/)(.*_xml.*)(\.php)$ /intranet/$2.php redirect;
        rewrite ^/module/(.*/)(.*erro_banco\.php)$ /intranet/erro_banco.php redirect;
        rewrite ^/module/(.*/)(.*educar_pesquisa_cliente_lst\.php)$ /intranet/educar_pesquisa_cliente_lst.php redirect;
        rewrite ^/module/(.*/)(.*educar_pesquisa_obra_lst\.php)$ /intranet/educar_pesquisa_obra_lst.php redirect;
        rewrite ^/module/(.*)$ /module/index.php last;
    }

    location ~ ^(/intranet.*\.php|/modules.*\.php|/module/) {
        rewrite ^(.*)$ /index.php$1;
    }

    location ~ \.php {
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass php-fpm;
        fastcgi_index index.php;
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
        fastcgi_param PATH_INFO $fastcgi_path_info;
        fastcgi_read_timeout 7200s;
    }

    location / {
        try_files $uri $uri/ /index.php?$query_string;
    }
}

Você pode dar uma olhada nos logs do servidor e da aplicação pra ver qual pode ser o problema:

Log do nginx: /var/log/nginx/error.log;
Log da aplicação: /pasta/de/instalacao/storage/logs

Veja se alguma informação ali te dá mais detalhes sobre qual é a origem do erro e manda aqui pra gente ver.

1 Curtida

Obrigado pela ajuda, descobri que o problema estava no limite de memória, peguei meu php.ini fiz o ajuste no memory_limit = -1 e aumentei o upload_max_filesize tbm e funcionou.

2 Curtidas