Tutorial de Instalação i-Educar v2.5.3 e automação

Boa noite mestres, sou novato aqui e gostaria de testar o i-Educar, no repositório no github senti falta de um passo a passo mais detalhado para instalar a ultima versão, por favor se alguém tiver um tutorial ou se alguém estiver disposto a me ajudar, queria montar um script para automatizar a instalação no ubuntu, quem quiser postar aqui scripts de configurações eu agradeço, vai me ajudar muito no desenvolvimento.
ex: tentei configurar no ubuntu 20.04 o PHP 7.4 com as dependências como pede no github, montei o script
sudo apt-get install -y php7.4-{bcmath,ctype,curl,dom,fileinfo,gd,iconv,json,libxml,mbstring,openssl,pcre,PDO,pgsql,Phar,SimpleXML,tokenizer,xml,xmlreader,xmlwriter,zip,zlib}

porem me retorna o erro:

E: Unable to locate package php7.4-libxml
E: Couldn't find any package by glob 'php7.4-libxml'
E: Couldn't find any package by regex 'php7.4-libxml'
E: Unable to locate package php7.4-openssl
E: Couldn't find any package by glob 'php7.4-openssl'
E: Couldn't find any package by regex 'php7.4-openssl'
E: Unable to locate package php7.4-pcre
E: Couldn't find any package by glob 'php7.4-pcre'
E: Couldn't find any package by regex 'php7.4-pcre'
E: Unable to locate package php7.4-zlib
E: Couldn't find any package by glob 'php7.4-zlib'
E: Couldn't find any package by regex 'php7.4-zlib'

Com os comandos prontos pra instalar o i-educar no linux fica mais fácil pra gente desenvolver um script pra automatizar a instalação agilizando assim a implantação.

Após isso também gostaria do arquivo do banco de dados para que eu possa configurar um BD no RDS da AWS para colocar o i-Educar em alta disponibilidade, construindo assim um projeto completo em nuvem.

Espero que compreendam minha intensão para melhorar mais ainda a instalação.
Obrigado! E parabéns pelo o projeto, que Deus abençoe a todos que estão buscando um país melhor contribuindo na evolução da educação.
#iEducar #DevOps

Você está confundindo extensão com pacote apt. São coisas diferentes.

No Ubuntu você pode utilizar pacotes apt para instalar e habilitar algumas extensões, mas o nome da extensão nem sempre é o mesmo do pacote.

Como o i-Educar pode ser instalado em diversos sistemas operacionais, e não necessariamente a instalação será via apt, é mais prudente definir quais extensões são necessárias.

Que arquivo de banco de dados?

Eu consegui fazer a instalação dos pacotes, vocês não usam datapump para montar a estrutura do banco de dados? Ou isso é feito por migrations direto da aplicação?

Isso é feito através das migrations e seeds do sistema.

Amigo,
No tutorial do 2.3.5 substitua somente o PHP7.3 PARA 7.4 o restante pode manter.

Obrigado a todos, mas eu consegui resolver com a ajuda de um parceiro no grupo do telegram

1 Curtida