Erro na Instalação I-Educar 2.2.20

Boa tarde pessoal, sou novo fórum e venho enfrentando dificuldades para instalar o I-Educar 2.2.20 no meu servidor Ubuntu 18.04. Sigo o passo-a-passo da instalação 2.1.x, realizando algumas atualizações de versões do programas, mas quando chego no processo de migrações a instalação para, diz que houve um erro e pede pra consultar um log na pasta storage. Fico muito grato pelo atenção de todos e dos puderem me ajudar.

Bom dia, posta o erro pra poder te ajudar.

Boa tarde Flávio. Aparece o seguinte erro na tela de migrações:

O erro é esse:

você está atualizando de uma versão pra outra ou uma nova instalação do zero, outra coisa ja tive problemas uma vez com isso, não lembro como resolvi, vou verificar e te aviso, tenta mudar de navegador.

Boa noite Flávio. Essa msg aparece quando estou instalando do zero. Um ponto interessante é que a versão 2.1.13 instala de boa, mas quando vou atualizar ele fica só pedindo pra aguardar e não conclui a atualização.

Segue o passo a passo da migração.

@uiltondeoliveira esse erro foi resolvido no pull request https://github.com/portabilis/i-educar/pull/703

Bata atualizar seu repositório e rodar a instalação novamente

Obrigado Everton, agora sim consegui instalar com sucesso. :clap: :clap:

Boa tarde @munizeverton, o erro continua, fui instalar a versão 2.2.20 no ubuntu 18.04.4 atualizando, quando roda o comando php composer.phar install, tem um erro de pacote depreciado, algum pacote desatualizado e o instalador não consegue baixa, por isso acontece erro na instalação quando vai rodar as migrações do instalador, depois posto o print do erro.

Pensei que era a versão do php, mas testei tanto com a 7.2, quanto com a 7.3 e o erro continua.

Certo @flavio. Quando puder posta o print do erro

@flavio tu resolveu o problema? Estou com o mesmo erro…

@Welmiton ainda não, não tive tempo essa semana, posta o print do erro no navegador, que não tive como fazer.

Dá erro em ‘Executando Migrações’

Creio que seja pacote quebrando quando roda o comando php composer.phar install ele não baixa alguns pacotes e por isso da o erro quando vai fazer a migração, a falta desse pacote, geralmente quando sair atualização, vai corrigir esse problema.

Boa tarde a todos, estou fazendo uma instalação nova e estou com o mesmo problema do uiltondeoliveira, exatamente a mesma tela, alguém já passou por isso e possa compartilhar uma dica?

Prezados, utilizem o postgresql 9.5 que tudo funcionará. Eu estava com o mesmo erro, estava usando a versão 12. Fiz o downgrade e tudo deu certo.