Ajuda com Reltórios

Boa tarde, Alguém pode me ajudar onde encontro oe relatórios para instalar ?

Se você está instalando a última versão, você não precisa instalar módulo de relatórios. No entanto, para que eles funcionem é necessário instalar o openjdk 8.

Agora, se você roda uma versão antiga que precisa, você vai achar as informações no Github da Portablis.

Bom dia, Senhores.

Vamos aos fatos.

O servidor que instalei o IEducar Tem a seguinte configuração.
Linux Mint 19.3
PostgresSql 10.1
IEducar 2.3.7
OpenJdk 11
E quando tento gerar algum relatório apresenta a mensgem abaixo. Alguém pode me dar uma luz.

Ocorreu um erro ao emitir o relatório. Detalhes: Exception in thread “main” java.lang.ClassCastException: class jdk.internal.loader.ClassLoaders$AppClassLoader cannot be cast to class java.net.URLClassLoader (jdk.internal.loader.ClassLoaders$AppClassLoader and java.net.URLClassLoader are in module java.base of loader ‘bootstrap’)

Bom dia!

Você precisa utilizar o Postgresql 9.5 e Openjdk 8.

Após ter essas versões tente novamente, postando o log caso tenha erro novamente.

Boa tarde, Tiago.
Obrigado pela ajuda.

Agora funcionou. Fiz o seguinte atualizei o iEducar para 2.3.10.
removi o OpenJDK 11, instalei o OpenJdk8 reiniciei o servidor e funcionou.
Agora meu Servidor está com a seguinte configuração!
Linux Mint 19.3
PostgresSql 10.1
IEducar 2.3.10
OpenJdk 8

Obrigado pessoal!

1 Curtida