Instalação do i-educar numa vps


#22

Vou dar uma olhada aqui no apache. Lembrando que estou tentando instalar no VPS da Locaweb, e nao na minha maquina local pra transforma-la em um servidor web.


#23

Tai, depois que de STOP no APACHE. Nao deu erro na instalacao do NGINX.


#24

Tem que garantir também que o Apache não vai iniciar após um reboot


#25

O que aconteceu depois q removi APACHE no meu SERVER. Acabou o conflito e mostra q o NGINX esta instalado corretamente. Porem ainda nao sei exatamente quais configuracoes devo fazer de acordo com meu VPS.


#26

Bom dia a todos do grupo,
Pessoal ainda nao conseguir fazer minha instalacao numa VPS, fiz as seguintes configuracoes.
1 - Antes de tudo faça download da versão mais recente do i-Educar.
2 - Para executar o i-Educar em um servidor você precisa dos seguintes programas:

3 - O Nginx precisa estar devidamente configurado para rodar o i-Educar e permitir acesso ao instalador. Você encontra um exemplo de configuração aqui.

4 - Em sistemas Ubuntu , por exemplo, você colocaria este arquivo na pasta /etc/nginx/sites-available e criaria um symlink para ele na pasta /etc/nginx/sites-enabled .

Não esqueça de adequar a configuração de acordo com a realidade do seu servidor principalmente as seguintes diretivas:

  • root
  • fastcgi_pass

#27

Seguem as telas.

minhas configuracoes ficaram asim:

ROOT: root /var/www/html/public;
FASTCGI: fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;

Esta dando esse erro.

Alguem pode me ajudar por favor.


#28

Bom dia, esses comandos devem ajudar

#instala o composer

curl -s https://getcomposer.org/installer | php
php composer.phar install
composer install


#29

2 comando deu isso ai


#30

opa, executar na pasta do projeto: /var/www/html/


#32


saiu isso na tela


#33

executa esse antes:
curl -s https://getcomposer.org/installer | php


#34

Agora deu certo amigo. Obrigado Robson…


#35


#36

Por nada @marcioro. Bom trabalho


#38

Acho que hoje dá certo, mas ainda vai ter alguns obstáculos


#39

TELA FINAL…

ACHO QUE DEU CERTO… PRIMEIRA VEZ Q VEJO ESSA TELA… kkkkkkk


#40

Agora tenta instalar


#41

ta dando erro no banco.

POREM olhei o arquivo .ENV e esta igual o instalado.

Robson ou alguem do grupo ;pode me ajudar por favor


#42

Aí pode ser dois motivos, ou o banco não foi criado ou o DB_HOST=postgres é inacessível. Aqui funcionou com DB_HOST=localhost e criando o banco pelo pgAdmin III


#43

estou nesse mesmo ponto e não conseguir por nada sair desse dilema @robson eu tentei dessa forma tbm mais não vai sera que você não poderia me ajudar ? não manjo nada de postgressql. como que abro esse pgAdmin, da pra fazer em uma vps ? eu ate ja instalei mais nao sei como abro e configuro na vps. se puder me ajudar eu agradeço