Erro ao instalar "tables declared WITH OIDS are not supported"

Ao tentar instalar o iEducar (2.3.0) no ubuntu 20.04 (nginx 1.18.0, PostgreSQL 9.5) acontece um erro ao rodar migrations.
O log me retorna o seguinte: Feature not supported: 7 ERROR: tables declared WITH OIDS are not supported

O log completo eu colei no pastebin: https://pastebin.com/6GHPPMja

Poderiam me ajudar? Estou tentando instalar em localhost para testar.

att.

@bruno_silva você pode executar psql --version e colocar o log para nós, só para confirmarmos a versão do Postgres.

1 Curtida

Desculpa, informei errado.
O comando retornou: psql (PostgreSQL) 12.2 (Ubuntu 12.2-4)

@bruno_silva sua instalação do Postgres está com a versão 12.2, porém o i-Educar precisa do 9.5 devido a algumas necessidades legadas.

Veja este link de como instalar no Ubuntu https://www.postgresql.org/download/linux/ubuntu/ versão antigas.

Certo, irei testar aqui e retorno.
Na doc diz “versão 9.5 ou superior”

Por isso mantive a 12.2

@bruno_silva teoricamente deveria funcionar, mas vamos atualizar a doc, valeu!