Video de instalação do i-diario

Mas tudo q fiz foi seguindo o video postado aqui. So que no video esta sendo instalado localmente no virtualbox. Por isso deu esse erro. Ja eu estou instalando o idiario no VPS diferente do ieducar.

A diferença é no comando que cria uma entidade, onde tem que informar o ip da vps (acho que o endereço também funciona) e não localhost

sei… vou dar uma voltada desde o inicio da minha instalacao pra ver se consigo colocar meu dominio no lugar de localhost

Boa noite a todos, ainda continuo na mesma. Acabei de fazer uma nova instalação do i-diario VPS. criei SERVER como no i-educar. Mesmo assim continua o mesmo problema de acesso ao meu dominio.

server {

index index.php index.html index.htm;
server_name cdaempresas.com www.cdaempresas.com;
error_log  /var/log/nginx/error.log;
access_log /var/log/nginx/access.log;
root /var/www/html/i-diariopublic;

location ~ ^/intranet/?$ {
    rewrite ^.*$ /intranet/index.php redirect;
}

location ~ /module/(.*)/(styles|scripts|imagens)/(.*) {
    rewrite ^/module/(.*)/(imagens|scripts|styles)/(.*)$ /intranet/$2/$3 break;
}

location ~ /module/(.*)/(.*) {
    rewrite ^/module/(.*/)(.*intranet/.*)$ /$2 redirect;
    rewrite ^/module/(.*/)(.*index\.php)$ /$2 redirect;
    rewrite ^/module/(.*/)(.*logof\.php)$ /intranet/logof.php redirect;
    rewrite ^/module/(.*/)(.*meusdados\.php)$ /intranet/meusdados.php redirect;
    rewrite ^/module/(.*/)(.*_xml.*)(\.php)$ /intranet/$2.php redirect;
    rewrite ^/module/(.*/)(.*erro_banco\.php)$ /intranet/erro_banco.php redirect;
    rewrite ^/module/(.*/)(.*educar_pesquisa_cliente_lst\.php)$ /intranet/educar_pesquisa_cliente_lst.php redirect;
    rewrite ^/module/(.*/)(.*educar_pesquisa_obra_lst\.php)$ /intranet/educar_pesquisa_obra_lst.php redirect;
    rewrite ^/module/(.*)$ /module/index.php last;
}

location ~ ^(/intranet.*\.php|/modules.*\.php|/module/) {
    try_files /index.php =404;
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
    fastcgi_index index.php;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $fastcgi_path_info;
}

location ~ \.php {
    try_files $uri =404;
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
    fastcgi_index index.php;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $fastcgi_path_info;
}

location / {
    try_files $uri $uri/ /index.php?$query_string;
}

}

DEPOIS

nano /etc/hosts

191.252.000.111 cdaempresas.com
191.252.000.111 www.cdaempresas.com

VEJAM AI

boa iniciativa em gravar um vídeo de como fazer a instalação do i-diario, bem que vc poderia fazer um vídeo de como instalar o i-educar em um ubuntu .

2 Curtidas

Nao tem video, mais se vc seguir meu tutorial provavelmente vc vai conseguir…

SEGUE TUTORIAL ATUALIZADO

Instalação em servidor NGINX - PHP 7.2 - POSTGRESQL 9.5

apt-get update

apt-get install nginx -y

apt-get install software-properties-common -y	

add-apt-repository ppa:ondrej/php -y

apt-get update	

apt-get install -y php7.2 php7.2-bcmath php7.2-curl php-dompdf php7.2-mbstring php7.2-pgsql php7.2-xml php7.2-zip php7.2-fpm php7.2-gd

apt-get install postgresql postgresql-contrib -y

apt-get update

BAIXAR I-EDUCAR

chmod -R 755 /var/www/html

rm /etc/nginx/sites-available/default

nano /etc/nginx/sites-available/default

Copiar o arquivo abaixo no default	

server {

index index.php index.html index.htm;
server_name MEUSITE.com.br www.MEUSITE.com.br;
error_log  /var/log/nginx/error.log;
access_log /var/log/nginx/access.log;
root /var/www/html/public;

location ~ ^/intranet/?$ {
    rewrite ^.*$ /intranet/index.php redirect;
}

location ~ /module/(.*)/(styles|scripts|imagens)/(.*) {
    rewrite ^/module/(.*)/(imagens|scripts|styles)/(.*)$ /intranet/$2/$3 break;
}

location ~ /module/(.*)/(.*) {
    rewrite ^/module/(.*/)(.*intranet/.*)$ /$2 redirect;
    rewrite ^/module/(.*/)(.*index\.php)$ /$2 redirect;
    rewrite ^/module/(.*/)(.*logof\.php)$ /intranet/logof.php redirect;
    rewrite ^/module/(.*/)(.*meusdados\.php)$ /intranet/meusdados.php redirect;
    rewrite ^/module/(.*/)(.*_xml.*)(\.php)$ /intranet/$2.php redirect;
    rewrite ^/module/(.*/)(.*erro_banco\.php)$ /intranet/erro_banco.php redirect;
    rewrite ^/module/(.*/)(.*educar_pesquisa_cliente_lst\.php)$ /intranet/educar_pesquisa_cliente_lst.php redirect;
    rewrite ^/module/(.*/)(.*educar_pesquisa_obra_lst\.php)$ /intranet/educar_pesquisa_obra_lst.php redirect;
    rewrite ^/module/(.*)$ /module/index.php last;
}

location ~ ^(/intranet.*\.php|/modules.*\.php|/module/) {
    try_files /index.php =404;
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
    fastcgi_index index.php;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $fastcgi_path_info;
}

location ~ \.php {
    try_files $uri =404;
    fastcgi_split_path_info ^(.+\.php)(/.+)$;
    fastcgi_pass unix:/var/run/php/php7.2-fpm.sock;
    fastcgi_index index.php;
    include fastcgi_params;
    fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param PATH_INFO $fastcgi_path_info;
}

location / {
    try_files $uri $uri/ /index.php?$query_string;
}

}

cd /var/www/html/

curl -s https://getcomposer.org/installer | php

php composer.phar install

apt-get install -y composer

apt-get update


nano /etc/nginx/nginx.conf

server_names_hash_bucket_size 64;


nginx -t

systemctl restart nginx

nano /etc/hosts

191.010.101.111 MEUSITE.com.br
191.010.101.111 www.MEUSITE.com.br


chown -R www-data:www-data /var/www/html/


nano /var/www/html/.env

DB_CONNECTION=pgsql
DB_HOST=localhost
DB_PORT=5432
DB_DATABASE=ieducar
DB_USERNAME=ieducar
DB_PASSWORD=MINHASENHA

service postgresql restart

sudo -u postgres createuser ieducar
sudo -u postgres psql
alter user ieducar with encrypted password 'MINHASENHA';
\q

sudo -u postgres psql
alter user ieducar with SUPERUSER;
\q

sudo -u postgres createdb ieducar
sudo -u postgres psql
grant all privileges on database ieducar to ieducar;
\q

nano /etc/postgresql/9.5/main/pg_hba.conf

# "local" is for Unix domain socket connections only
local all all peer

por:

“local” is for Unix domain socket connections only

local all all md5

service postgresql restart

Instalação do i-Educar
MEUSITE.com.br/install.php

Instalação do pacote de relatórios

cd /var/www/html/

apt-get update

apt-get install default-jdk -y

git clone https://github.com/portabilis/i-educar-reports-package.git ieducar/modules/Reports

chmod -R 755 /var/www/html

composer new-install

php artisan reports:install

chmod -R 755 /var/www/html/ieducar/modules/Reports

php artisan reports:compile

chmod -R 777 /var/www/html/ieducar/modules/Reports/ReportSources

Mudanca da logo em documentos e relatorios

Caminho de hospedagem da logo.

ieducar/modules/Reports/ReportLogos/logo-pm.png

sudo -u postgres psql

\c ieducar

INSERT INTO public.settings (key, value, type, description, created_at, updated_at) VALUES (‘legacy.report.logo_file_name’, ‘logo-pm.png’, ‘string’, null, now(), now());

UPDATE public.settings SET value = ‘logo-pm.png’ WHERE key = ‘legacy.report.logo_file_name’;

Boa Noite, já possuo o I-educar instalado conforme tutorial e dependências exigidas para a instalação e funcionamento, uma dúvida pretendo instalar o I-diario na mesma maquina que esta instalado o I-educar, já possuo o postgresql 9.5 instalado, no vídeo do i-diario mostra a instalação do postgresql, devo instalar a versão 10, ou pulo essa parte por já ter instalado quando foi configurado o i-educar?

Utilizo o i-Diario 1.0.8 com o postgresql 9.5. Não se sei versões mais recentes exigem o postgresql 10

Obrigado, pelo retorno @robson não é pela versão do postgres é sim pelo fato da ferramenta já estar instalado, e pela documentação fala da versão 9.5, mas optei por seguir sem a parte do postgres mas ocorreu um erro na instalação do ‘bundle’ conforme copia da telaCaptura de tela de 2020-02-14 12-40-22 , como posso resolver esse erro?

Obrigado.

Esse ‘pg’ que aparece no erro tenho quase certeza que é o postgresql que está faltando.

Opa, boa tarde, mas o postgres está instalado e a versão que estou usando e a versão 9.5, conforme tela capturada
Captura de tela de 2020-02-14 13-16-55 estou perdido, até porque o i-Educar está funcionando normal, acho que esqueci de mencionar que estou usando o Ubuntu 18.04.
Obrigado

Humm, ‘pg’ é uma gem do Ruby, deveria ter sido instalada quando rodou o bundle. Tenta o comando:
gem install pg -v '0.17.1' --source

@robson, retorna esse erro ao executar o comando que vc passougem install pg -v '0.17.1' --source conforme captura

pelo que estou entendendo o tal gem está sendo executado, acho :slightly_smiling_face: como faço para parar se for caso?
Obrigado.

Faltou o final, segue o comando completo

gem install pg -v '0.17.1' --source 'https://rubygems.org/'

Consegui instalar o bundle, assistindo o video novamente, não era instalação do postgresql e sim uma dependencia com o comando" sudo apt-get install postgresql-9.5 libpq-dev" instalando a dependecia o bundle instalou normal, obrigado @robson pelo seu tempo e paciencia, vou seguir o resto do tutorial.
Obrigado.

Consegui instalar o I-diario está funcionando só uma dúvida não consigo acessar o mesmo de outro computador, somente direto no servidor, usando localhost, tem como liberar acesso externo?

Obrigado

Tem sim, alterando o registro da tabela ‘entities’

Boa Noite @robson, como acesso essa configuração ?

Acessando o banco de dados, pode ser pelo shell (psql), pelo pgadmin4 ou outra plataforma de administração do banco de dados.

@robson, ok obrigado.